Changes to System Requirements FAQs - GoToMeeting

Find an Answer

Search GoToMeeting articles, videos and user guides   Your search term must have 2 or more characters.

Browse Articles

Changes to System Requirements FAQs

To make sure our GoToMeeting, GoToWebinar and GoToTraining desktop app is simple and reliable, we use the latest technology in our product updates and improvements. This means that we sometimes have to trade out support for an older browser or operating system so that we can focus instead on improving the quality of our products and building new and innovative things.

Topics in this article:

Which operating systems are supported?

Why do you discontinue support of older operating systems?

Does this mean that I can't start sessions as an organizer from these operating systems?

Changes to System Requirements FAQs

Does this affect my attendees?

How do I upgrade my operating system?

Which operating systems are supported?

There are multiple ways for you and your attendees to access GoToMeeting, GoToWebinar, and GoToTraining, and each method has different system requirements. See below for the most undated info:

Why do you discontinue support of older operating systems?

It takes a lot of time and resources for us to support each individual operating system, and we want to invest those resources into making our products better for you! Therefore, we regularly discontinue support for older operating systems once Microsoft and Apple discontinues their support of them.

Does this mean that I can't start sessions as an organizer from these operating systems?

If you are a GoToMeeting organizer, then this does not prevent you from hosting your sessions on your existing operating system! Even though you can't use the desktop app, you can still host your sessions online using Google Chrome for the time being using the browser-based Web App.

However, please keep in mind that since Google Chrome has also dropped support for these older operating systems, we cannot continue to support it indefinitely. The Web App will continue to work right now, but we highly recommend that you upgrade your operating system as soon as possible, because we will not be able to fix any bugs or issues with the older operating systems that may arise in the future.

If you are a GoToWebinar or GoToTraining organizer, then you will not be able to start sessions from these operating systems. Since it is not possible for you to host sessions using the browser-based Instant Join app, you will need to upgrade your operating system to download the latest build of the desktop app.

Does this affect my attendees?

Yes. Your attendees also will not be able to install the desktop app if they are on an older operating system. However, they join sessions from within their web browser or using their mobile device instead.

Note that some session features may vary by browser – see below for more details:

 

Google Chrome
(recommended)

Mozilla Firefox
Safari
Internet Explorer
GoToMeeting Web App

VoIP or Dial-in audio

Dial-in only audioDial-in only audioDial-in only audio
GoToWebinar Instant Join App VoIP or Dial-in audioDial-in only audioNot availableNot available
GoToTraining Instant Join App VoIP or Dial-in audioNot availableNot availableNot available

However, please keep in mind that since Google Chrome has also dropped support for these older operating systems, we cannot continue to support it indefinitely. The browser-based apps will continue to work right now, but we highly recommend that your attendees upgrade their operating systems as soon as possible, because we will not be able to fix any bugs or issues with the older operating systems that may arise in the future.

How do I upgrade my operating system?

It depends on your current operating system. In some cases, you can upgrade for free! Learn more here: