Mac OS X 10.7 Lion FAQs - GoToAssist Express

Find an Answer

Search GoToAssist Express articles, videos and user guides   Your search term must have 2 or more characters.

Mac OS X 10.7 (Lion) FAQs

The new Mac Lion OS promises to be a great upgrade for Mac customers. It includes over 250 new features and many usability enhancements. We have been working closely with Apple and testing our products with this new OS. There are a few known issues that our Mac customers should be aware of if they upgrade to Lion.

Note for GoToManage Remote Support technicians: References to “the GoToAssist Express application” below are referring to the application that you download onto your computer to use GoToManage Remote Support.

Yes, as long as you have Java installed on your Mac and your customer is using a PC or Mac OS X 10.6 (Snow Leopard) or older. GoToAssist Express requires Java to download the application, so since OS X Lion does not include Java you will need to install it before downloading the application (see “Java is not installed on OS X Lion. Do I need it to host or join a session?” for more information).

  • If your customer is using Mac OS X 10.7 (Lion): You must use GoToAssist Express 1.6, build 309 or newer to start the support session or you will encounter errors (see “Will my current version of GoToAssist Express work with OS X Lion?” for more information). Also, because GoToAssist Express requires Java to launch the application, your customer will need to install Java (if they haven’t already) in order to join the support session (see “Java is not installed on OS X Lion. Do I need it to host or join a session?” for information on downloading Java).

Yes, but if your customer is using OS X Lion then you must use GoToAssist Express 1.6, build 309 or newer to start the support session. If you use an older build, you will not be able to see your customer’s screen once you start the support session (See “Will my current version of GoToAssist Express work with OS X Lion?” for more information).

Customers using OS X Lion will also need to install Java before joining the support session (see “Java is not installed on OS X Lion. Do I need it to host or join a session?” for information on downloading Java).

If your customer is using Mac OS X 10.7 (Lion), then you must use GoToAssist Express 1.6, build 309 or newer to start the support session . If you use an older build, you won’t be able to see your customers screen when they join the session.

To see which version of GoToAssist Express you’re using, do the following:

  1. Launch the GoToAssist Express application (if it isn’t already running).
  2. On a PC, right-click the GoToAssist daisy icon ( ) in your system tray and select About. On a Mac, click GoToAssist Express in the menu bar and select About GoToAssist.
  3. The version and build number are listed in the About – GoToAssist window.

If you need to upgrade to the newest version of GoToAssist Express, complete the following steps:

  • Upgrading on a Mac:
  1. If you are using OS X Lion, make sure that you have Java installed (see “Java is not installed on OS X Lion. Do I need it to host or join a session?” for information).
  2. Start a GoToAssist Support session.
  3. Click GoToAssist Express in the menu bar, and select Check for Update.
  4. A dialog box appears indicating if a new version of GoToAssist Express is available.
  5. If a new version is available, click Yes to begin downloading the latest version.
  • Upgrading on a PC:

1. Right-click the GoToAssist daisy icon () in your system tray and select Check for Update.

Note: The Check for Update option is disabled when you are in a session. If the GoToAssist daisy icon () does not appear in your system tray at all, start a GoToAssist Express support session and then end the session without exiting the GoToAssist Express application.

2. A dialog box appears indicating whether or not a new version of GoToAssist Express is available.

3. If they are, click Yes to begin downloading the newest version.

Java is not installed on OS X Lion. Do I need it to host or join a session?

If you are using OS X Lion, you must have Java installed on your computer in order to download the GoToAssist Express application to host or join a session because OS X Lion does not come with Java pre-installed (this is a one-time download of approximately 130 MB).

If you try to host or join a session without Java installed, you will see a "Missing Plug-in" message instead of the download progress bar on the Download page. You can click Missing Plug-in to initiate an automatic Java download. Alternatively, you can download Java directly from Apple's support site at http://support.apple.com/kb/DL1421.

Installing Java Automatically: To install Java automatically, log in to your account at www.GoToAssist.com and click Start a Support Session (customers should click the link in the invitation email or go to www.FastSupport.com and enter the support key supplied by the technician). From the Download page, complete the following steps:

1. When the application tries to download, a "Missing Plug-in" message appears instead of the download progress bar on the Download page. Click Missing Plug-in .

IMAGE HERE

2. When the following pup-up message appears, click Install.

3. When the following License Agreement appears, click Agree.

4. When the following Download Progress bar appears, Java will begin automatically downloading and installing the necessary packages (approximately 130 MB).

5. After installation is complete, you will need to refresh the page or simply launch the support session again. You will then be able to host GoToAssist Express support sessions from Mac OS X Lion without being asked to download Java again.

Should you have any questions about using GoToAssist Express with the new Mac Lion OS, please feel free to contact your account manager or call our toll-free 24/7 support line.

Did this article answer your question?
Yes
No
Why?