System Requirements for Outlook Plugin - OpenVoice - LogMeIn

Find an Answer

Search OpenVoice articles, videos and user guides   Your search term must have 2 or more characters.

Browse Articles

System Requirements for Outlook Plugin

Please check to see that you meet the minimum system requirements before downloading the latest version of the OpenVoice Outlook Plugin.

Windows
Operating SystemWindows 10
 Windows 8
 Windows 7
 Windows Vista
 Windows XP (Service Pack 2)
Processor Intel®Core™ 2 Duo class processor or better
RAM2 GB or more
Internet Dedicated broadband Internet connection with HTTPS/SSL firewall access for outbound connections recommended
Additional software.NET Framework 4.0 or newer
 OpenVoice organizer account

Supported Desktop Configurations

  • Microsoft Office 2010 – 2016
  • Single installer package for Outlook 2010 (32-bit and 64-bit) and 2013 (32-bit and 64-bit)
  • Single- and multiple-user accounts
  • MSI files that are primarily designed for administrators to create their own installation package
  • Exe files that are designed for users who are administrators of their own machine and not in a controlled environment